Bienvenue, Invité. Merci de vous connecter ou de vous inscrire.
Avez-vous perdu votre e-mail d'activation ?

Auteur Sujet: [RESOLU] L'image refuse de s'afficher  (Lu 192 fois)

0 Membres et 1 Invité sur ce sujet

OverMath

  • Newbie
  • *
  • Messages: 3
    • Voir le profil
[RESOLU] L'image refuse de s'afficher
« le: Juin 14, 2020, 09:25:17 pm »
Bonsoir, je débute avec la SFML et donc je suis le tutoriel dédié, j'en suis à la partie chargement de la texture, seulement voilà, lorsque j'exécute, ou je débogue, la console, et le débogueur m'affiche : "Failed to load image "©└icon.png ╠╠╠╠╠╠      ╠╠╠╠╠╠╠╠", ce qui ne m'aide vraiment pas à comprendre le problème... j'ai essayer avec d'autres images, le résultat est le même. L'image est bien dans le répertoire de travail courant aux cotés du fichier main.cpp. Autre info utile je suis sous l'IDE VisualStudio, je pense l'avoir bien configuré, et dans le fichier debug du projet il y a bien les dll. Si quelqu'un peux m'aider je lui en serais grandement reconnaissant! Voici le morceau de code en question :
#include <SFML/Graphics.hpp>

int main()
{
    sf::Texture texture;
    if (!texture.loadFromFile("icon.png"))
        return EXIT_FAILURE;

    return 0;
}
 
« Modifié: Juin 15, 2020, 05:34:01 pm par OverMath »

G.

  • Hero Member
  • *****
  • Messages: 1462
    • Voir le profil
Re: L'image refuse de s'afficher
« Réponse #1 le: Juin 15, 2020, 12:00:27 am »
Il est important de lier les bibliothèques qui correspondent à la configuration : "sfml-xxx-d.lib" pour Debug, et "sfml-xxx.lib" pour Release. Un mauvais mélange pourrait entraîner des crashs.
Est-ce bien le cas ?

OverMath

  • Newbie
  • *
  • Messages: 3
    • Voir le profil
Re: L'image refuse de s'afficher
« Réponse #2 le: Juin 15, 2020, 07:16:41 am »
Oui c'est bien le cas, c'est l'une des premières choses que j'ai vérifié, les fichier sfml-xxx-d.lib sont bien liés comme ceux sfml-xxx.lib... J'ai essayé d'utiliser SFML pour afficher une fenêtre, et cela fonctionne, ce qui me porte à croire que ce n'est pas dans la configuration de SFML que réside le problème...

PS: Finalement après avoir passé ma journée à faire des test à réfléchir j'ai finalement réussi à faire marcher ce code, et je n'avais pas compris ton message, mais maintenant je le comprends, j'avais belle et bien mis les fichier de release et de debug ensemble dans l'éditeur de lien et maintenant que je les ai remis à leurs bons emplacement  respectifs, tout va mieux! ;D ;D
« Modifié: Juin 15, 2020, 05:31:43 pm par OverMath »